iRecord App 4.0.0

32 posts / 0 new
Last post
karolis
iRecord App 4.0.0

v4.0.0 CHANGELOG:

  • Update the species list
  • Recorder 6 style taxa search (5 character shortcuts).
  • Add taxon search filters for common and latin names.
  • Migrate user data to a more persistent internal storage (iOS low device space fix)
  • Performance improvements.
  • UX improvements.
  • Bug fixes.

Please let me know if you would like to test or found issues with the upcoming new release of the app. Thanks!

karolis
report

GrahamCheckley:

I was prompted to install the version 4 android app yesterday and I've identified the following problems.

1) Trying to add a record reports location missing while map shows a valid grid reference.

2) If I type Abundance Individuals 3 it shows as 2, trying to type double figures produces nonesense numbers, the back space doesn't work for single figures in this box either and the slide is questionable - trying to count 20 Mallard I could only slide 19 or 21.

3) After adding 30 records (or there abouts) to the app, any additional records no longer appear at the top of the app record list.  In order to see them I have to scroll down and back up through the records.  When that sometimes didn't work I had to stop and restart the app.

4) After sending 8 individual records I had to stop and restart the app to successfully send each subsequent record.

5) All of my past locations have been cleared out on installing this version.

I'm using a Samsung Galaxy S8, Android version 8.0.0

 

6) Count of butterflies doesn't show up on list page

Hi Graham, (sorry, the original forum thread with your issues has been accidentally deleted ¯\_(ツ)_/¯ ) Thanks very much for reporting the issues. I should have now fixed your reported 2, 3, 4, 5 and 6 issues. Try updating the app and please let me know if you see any more problems and thanks again for testing!

Thanks,

Karolis

GrahamCheckley
Yes, 2, 4, 5 and 6 are working fine

Dear Karolis

Yes, 2, 4, 5 and 6 are working fine.  I haven't accumulated enough records yet in a day to properly test 3 again, but you'd fixed that earlier on.

Best regards

Graham

karolis
Thanks

Cool, this is good to hear! Let me know if you enounter anything else, your feedback has been very useful.

Thanks,
Karolis

Origen
App 4

Comment section does not seem to be working. Type it in, then press 'done'.  Unable to go back from the page and if I restart app the comment is lost.

karolis
Thanks for reporting this. I

Thanks for reporting this. I have fixed it now with the next app update that should come out shortly 4.0.0 (5).

GrahamCheckley
I'm now on 4.0.0 (5) but..

I'm now on 4.0.0 (5) but I note that 1) Trying to add a record reports location missing while map shows a valid grid reference still isn't working.

Best regards, Graham

karolis
Thanks Graham, do you use GPS

Thanks Graham, do you use GPS to set the location for your records or do you manually type in the GridRef or select the square on the map? Also, does the record-edit page (the one with the Send button in the header) shows both the gridref and the location name?

 

Thanks!

GrahamCheckley
I'm using the phone GPS to

I'm using the phone GPS to set the location of my records.  The record-edit page reports "location missing" every time, but a location name will be present if I've locked that from previous records.  I can get the grid reference to appear by touching location in the record-edit page, selecting the red highlighted square on the displayed map, and then touching the back key to return to the record-edit page.

Best regards, Graham.

karolis
I have made a fix relating to

I have made a fix relating to this, could you please let me know if the issue is fixed now?

Thanks,
Karolis

GrahamCheckley
Location missing problem is fixed on v4.0.0 (6)

Location missing problem is fixed on v4.0.0 (6)

karolis
Superb, thanks again Graham  

Superb, thanks again Graham yes (this is supposed to look like a thumbs up)

GrahamCheckley
App problems since latest Android update

I've noticed that since my phone started running Android version 9 I'm seeing a couple of problems with the App.

1) When adding the first record the keyboard appears but the cursor isn't in the species name box.  So you start to type and nothing happens.

2) When I'm adding new records I sometimes find that the grid reference isn't updating to the new location, the map shows the old location too.  I can get round this by running my GPS logger app at the same time as the iRecord app, this keeps the phone GPS running all the time and everything works fine then.

Any ideas?  Best regards, Graham

karolis
Thanks Graham, I will look

Thanks Graham, I will look into this.

GrahamCheckley
Just to clarify (1)

Just to clarify (1).

Add and submit a list of records then restart the app. Now press the plus key, the cursor isn't in the species box, so typing doesn't work.

Paul Brazier
Error message saying that Location is missing

Same issue as Graham? in February. Location not being accepted. I'm using the RHS leotard slug route in.

karolis
I have fixed the species

I have fixed the species search keyboard focus issue and updated the species list in the current Beta version (v4.0.2). I haven't figured it out why Location page has the issue yet, but I am working on it.

Karolis

GrahamCheckley
This seems to have introduced

This seems to have introduced another bug. While the cursor now behaves properly, a spurious entry is displayed in the species list no matter what I type in.

The third entry in my predefined species list from my statistics is Ringlet. If I type in Mistle Thrush in the species box I am given a list of two species, Ringlet and Mistle Thrush.

karolis
Hi Graham, thanks a lot for

Hi Graham, thanks a lot for reporting the issues, it is increadibly useful to me! I have made a change to the app, not 100% sure this fixes the issue, could you check if your issue is gone now?

Regarding the location issue, just want to double check if I understood this correctly: the only issue regarding the location functionality is that sometimes the gridref isn't updated when creating a new record, but this is working OK when another app is using the GPS on the device, is that correct?

Thanks,
Karolis

GrahamCheckley
Still seeing the same problem

Still seeing the same problem with the new version, i.e. Ringlet pops up at the top of every list as soon as I start typing.

Re the location problem, your description is spot on. 

GrahamCheckley
Species list now working ok

Species list now working ok on 4.0.2 (3).

Location seems to be the only remaining problem.

GrahamCheckley
Limit on the number of locations?

Just to mention that on 25th May I used the iRecord app to record 96 observations.  This wiped all of my older saved locations, ones that I use regularly and that I hold on to to avoid re-typing location names.  Assuming that there is a limit to the number of locations would it be possible to get it increased to c250?

Best regards, Graham

p.s. the previously reported grid reference location problem is still there.  There may be some time dependency, if it's 10 minutes or so between records the grid reference is more likely to be correct. 

karolis
Yeah, it's a max 100

Yeah, it's a max 100 locations at the moment, I will increase it to 250 and will also make it that favourite locations are never removed when exceeding this.

Thanks.

vincek1
iRecord App 4.0.0

Hi I am fed up with all the rude comments about an app.

I admit takes a bit of getting used to but that said enables a lot of complex information to be gathered in a convenient way.

Vince

 

 

GrahamCheckley
Problem switching between an activity and default on 4.0.2 (3)

Dear Karolis

I've recently started to use an activity called "HES Wildlife recording" with version 4.0.2 (3), and I think I've come across a problem switching between this activity and the default of no activity.

I was out at 2 sites in the morning and recorded 3 records with the no activity default.  I then visited Holyrood Park, a HES Wildlife recording site and input 15 records against that activity.  On leaving Holyrood Park I tried to switch back to the no activity default but the radio button didn't work, the app remained stuck on HES Wildlife recording.  I then decided to shut the app down and start it again, this allowed me to change from the HES Wildlife recording activity to the no activity default, but doing this removed the HES Wildlife recording activity flag from all of the 15 records.

I've tried to reproduce the problem but so far the switching seems to be working OK now, but what I have discovered is that if I switch back to the no activity default and then restart the app, all of the HES Wildlife recording activity flags disapear from the flagged records. Similarly, if I remain in the HES Wildlife recording activity and restart the app the HES Wildlife recording flag disapears from all of the flagged records.  This reminds me a bit of the old disapearing location names problem that we saw with the earlier beta testing...

i'm using a Samsung Galaxy S10+ with Android version 9.

Best regards

Graham

 

karolis
Thanks Graham! Yeah, sounds

Thanks Graham! Yeah, sounds like a bug, I will have a look at this once I find some time. (and thanks for the patience, I have been busy with other projects lately, but I plan to dedicate some more time to the iRecord App this Autumn).

Karolis   

GrahamCheckley
Thank you!  Can I  just

Thank you!  Can I  just mention that the location lag problem that I mentioned previously is still an issue, although it seems to be less of a problem on my S10+ than it was on my S8.  In any case if I'm doing a lot of observations then I just run the GPS Logger app in the background as it keeps the location up to date and hence speeds up the iRecord app data entry.

Best regards

Graham

karolis
Yes, somehow the GPS lagging

Yes, somehow the GPS lagging or caching the last location. I will experiment with getting multiple GPS readings from the device before attaching a location to the record.

GrahamCheckley
Just to let you know that I

Just to let you know that I no longer seem to be seeing this GPS problem with Android version 10.  So the only issues I now have are the roll over in the number of locations and loosing the recording activity against a record when I restart the app.

karolis
Thanks Graham, we are in the

Thanks Graham, we are in the process of releasing a new app version now.

Paul Denning
App crashing

Hi Karolis - I've been using the App successfully now for the past year. Since I upgraded to iOS 13.3 on my iPhone Xs, it crashes when I enter either date or location data. The return arrow on the top of the screen disappears and I have to restart the phone in order to complete my record. - Any thoughts?

karolis
Hi Paul, thanks for reporting

Hi Paul, thanks for reporting this. I will have a look at it shortly. We are about to release a new app version and I will try to fix this issue before then.

Log in or register to post comments